const regex = /^(?:[^.\r\n]+\.){11}([^.\r\n]+)\.([^.\r\n]+)\.(?!ok\b|cancelled\b)([^.\r\n]+)\.(?:[^.\r\n]+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[^.\\r\\n]+\\.){11}([^.\\r\\n]+)\\.([^.\\r\\n]+)\\.(?!ok\\b|cancelled\\b)([^.\\r\\n]+)\\.(?:[^.\\r\\n]+)$', 'gm')
const str = `group.cluster.namespace.release.app.pod.timer.grpc.server.processing.duration.package.method.ok.count
group.cluster.namespace.release.app.pod.timer.grpc.server.processing.duration.package.method.cancelled.count
group.cluster.namespace.release.app.pod.timer.grpc.server.processing.duration.package.method.error.count`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}