use strict;
my $str = 'group.cluster.namespace.release.app.pod.timer.grpc.server.processing.duration.package.method.ok.count
group.cluster.namespace.release.app.pod.timer.grpc.server.processing.duration.package.method.cancelled.count
group.cluster.namespace.release.app.pod.timer.grpc.server.processing.duration.package.method.error.count';
my $regex = qr/^(?:[^.\r\n]+\.){11}([^.\r\n]+)\.([^.\r\n]+)\.(?!ok\b|cancelled\b)([^.\r\n]+)\.(?:[^.\r\n]+)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}