#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)e(?:pisode)?\s*(\d{1,3}(?!\d)|\d\d\d??)(?:-?e?(\d{1,3}))?(?!\d)"
Local $sString = "some.random.tv.show.s01episode01.1080p" & @CRLF & _
"some.random.tv.show.s01episode 01.1080p" & @CRLF & _
"some.random.tv.show.s01episode1.1080p" & @CRLF & _
"some.random.tv.show.s01episode 1.1080p" & @CRLF & _
"some.random.tv.show.s01e01.1080p" & @CRLF & _
"some.random.tv.show.s01e1.1080p" & @CRLF & _
"some.random.tv.show.s01e0102.1080p" & @CRLF & _
"some.random.tv.show.s01e01-02.1080p" & @CRLF & _
"some.random.tv.show.s01e01e02.1080p" & @CRLF & _
"some.random.tv.show.s01e01-e02.1080p" & @CRLF & _
"some.random.tv.show.s01e199.1080p" & @CRLF & _
"some.random.tv.show.s01e001004.1080p" & @CRLF & _
"some.random.tv.show.s01e1-e2.1080p" & @CRLF & _
"some.random.tv.show.s01e001-e002.1080p"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")