re = /e(?:pisode)?\s*(\d{1,3}(?!\d)|\d\d\d??)(?:-?e?(\d{1,3}))?(?!\d)/m
str = 'some.random.tv.show.s01episode01.1080p
some.random.tv.show.s01episode 01.1080p
some.random.tv.show.s01episode1.1080p
some.random.tv.show.s01episode 1.1080p
some.random.tv.show.s01e01.1080p
some.random.tv.show.s01e1.1080p
some.random.tv.show.s01e0102.1080p
some.random.tv.show.s01e01-02.1080p
some.random.tv.show.s01e01e02.1080p
some.random.tv.show.s01e01-e02.1080p
some.random.tv.show.s01e199.1080p
some.random.tv.show.s01e001004.1080p
some.random.tv.show.s01e1-e2.1080p
some.random.tv.show.s01e001-e002.1080p'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end