import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "e(?:pisode)?\\s*(\\d{1,3}(?!\\d)|\\d\\d\\d??)(?:-?e?(\\d{1,3}))?(?!\\d)";
final String string = "some.random.tv.show.s01episode01.1080p\n"
+ "some.random.tv.show.s01episode 01.1080p\n"
+ "some.random.tv.show.s01episode1.1080p\n"
+ "some.random.tv.show.s01episode 1.1080p\n"
+ "some.random.tv.show.s01e01.1080p\n"
+ "some.random.tv.show.s01e1.1080p\n"
+ "some.random.tv.show.s01e0102.1080p\n"
+ "some.random.tv.show.s01e01-02.1080p\n"
+ "some.random.tv.show.s01e01e02.1080p\n"
+ "some.random.tv.show.s01e01-e02.1080p\n"
+ "some.random.tv.show.s01e199.1080p\n"
+ "some.random.tv.show.s01e001004.1080p\n"
+ "some.random.tv.show.s01e1-e2.1080p\n"
+ "some.random.tv.show.s01e001-e002.1080p";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}