import Foundation
let pattern = #"e(?:pisode)?\s*(\d{1,3}(?!\d)|\d\d\d??)(?:-?e?(\d{1,3}))?(?!\d)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
some.random.tv.show.s01episode01.1080p
some.random.tv.show.s01episode 01.1080p
some.random.tv.show.s01episode1.1080p
some.random.tv.show.s01episode 1.1080p
some.random.tv.show.s01e01.1080p
some.random.tv.show.s01e1.1080p
some.random.tv.show.s01e0102.1080p
some.random.tv.show.s01e01-02.1080p
some.random.tv.show.s01e01e02.1080p
some.random.tv.show.s01e01-e02.1080p
some.random.tv.show.s01e199.1080p
some.random.tv.show.s01e001004.1080p
some.random.tv.show.s01e1-e2.1080p
some.random.tv.show.s01e001-e002.1080p
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)