using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!-)(?!.*-.*-)[\d-]{0,5}\d$";
string input = @"5
55-33
4444-1
1-4444
666666
Example of invalid strings
-3
6666-
5555-6666
2-2-2";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}