use strict;
my $str = '5
55-33
4444-1
1-4444
666666
Example of invalid strings
-3
6666-
5555-6666
2-2-2';
my $regex = qr/^(?!-)(?!.*-.*-)[\d-]{0,5}\d$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}