re = /^(?!-)(?!.*-.*-)[\d-]{0,5}\d$/m
str = '5
55-33
4444-1
1-4444
666666
Example of invalid strings
-3
6666-
5555-6666
2-2-2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end