$re = '/^(?!-)(?!.*-.*-)[\d-]{0,5}\d$/m';
$str = '5
55-33
4444-1
1-4444
666666
Example of invalid strings
-3
6666-
5555-6666
2-2-2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);