using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(010203)|(0102)|(01)";
string input = @"0102030405
0102203035";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}