$re = '/(010203)|(0102)|(01)/';
$str = '0102030405
0102203035';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);