const regex = /(010203)|(0102)|(01)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(010203)|(0102)|(01)', '')
const str = `0102030405
0102203035`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}