package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(010203)|(0102)|(01)`)
var str = `0102030405
0102203035`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}