package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[[:ascii:]]*[@][A-z0-9_.-]*`)
var str = `ale.vegas@ahoo.co.uk
ale.vegas@yahoo.co.uk`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}