$re = '/[[:ascii:]]*[@][A-z0-9_.-]*/';
$str = 'ale.vegas@ahoo.co.uk
ale.vegas@yahoo.co.uk';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);