package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((?:\w+\s?){1,12}).*`)
var str = `w1 w2 w3 w4 w5 w6 w7 w8 w9 w10 w11 w12. w13 w14 w15`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}