re = /^((?:\w+\s?){1,12}).*/m
str = 'w1 w2 w3 w4 w5 w6 w7 w8 w9 w10 w11 w12. w13 w14 w15'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result