const regex = /^((?:\w+\s?){1,12}).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?:\\w+\\s?){1,12}).*', 'gm')
const str = `w1 w2 w3 w4 w5 w6 w7 w8 w9 w10 w11 w12. w13 w14 w15`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);