import re
regex = re.compile(r"^((?:\w+\s?){1,12}).*", flags=re.MULTILINE)
test_str = "w1 w2 w3 w4 w5 w6 w7 w8 w9 w10 w11 w12. w13 w14 w15"
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)