using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+\/\d+\/\d+|(\b\w+[-\/\.]\w+\b)";
string input = @"Foo [1234-101] bar 456B/102 baz 5/3/2016";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}