$re = '/\d+\/\d+\/\d+|(\b\w+[-\/\.]\w+\b)/';
$str = 'Foo [1234-101] bar 456B/102 baz 5/3/2016';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);