re = /\d+\/\d+\/\d+|(\b\w+[-\/\.]\w+\b)/
str = 'Foo [1234-101] bar 456B/102 baz 5/3/2016'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end