// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\d+\/\d+\/\d+|(\b\w+[-\/\.]\w+\b)").unwrap();
let string = "Foo [1234-101] bar 456B/102 baz 5/3/2016";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}