package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d{1,2}) (\w+) (\d{4})`)
var str = `Company registered on 16 March 2003
Activity between 10 May 2006 an 10 July 2008 - no changes.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}