const regex = /(\d{1,2}) (\w+) (\d{4})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{1,2}) (\\w+) (\\d{4})', 'g')
const str = `Company registered on 16 March 2003
Activity between 10 May 2006 an 10 July 2008 - no changes.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}