$re = '/(\d{1,2}) (\w+) (\d{4})/';
$str = 'Company registered on 16 March 2003
Activity between 10 May 2006 an 10 July 2008 - no changes.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);