import Foundation
let pattern = #"(\d{1,2}) (\w+) (\d{4})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Company registered on 16 March 2003
Activity between 10 May 2006 an 10 July 2008 - no changes.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)