package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([\[\|\]])\w+`)
var str = `[[match this]] and this [[match that]], too.`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}