use strict;
my $str = '[[match this]] and this [[match that]], too.';
my $regex = qr/([\[\|\]])\w+/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";