re = /([\[\|\]])\w+/
str = '[[match this]] and this [[match that]], too.'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result