import re
regex = re.compile(r"([\[\|\]])\w+")
test_str = "[[match this]] and this [[match that]], too."
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)