using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\+?\d{1,3}[.\-\s]?)?(\(\d{3}\)|\d{3})?[.\-\s]?\d{3}[.\-\s]?\d{4}$";
string input = @"+1(425)-888-8080";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}