$re = '/^(\+?\d{1,3}[.\-\s]?)?(\(\d{3}\)|\d{3})?[.\-\s]?\d{3}[.\-\s]?\d{4}$/';
$str = '+1(425)-888-8080';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);