re = /^(\+?\d{1,3}[.\-\s]?)?(\(\d{3}\)|\d{3})?[.\-\s]?\d{3}[.\-\s]?\d{4}$/
str = '+1(425)-888-8080'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end