// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(\+?\d{1,3}[.\-\s]?)?(\(\d{3}\)|\d{3})?[.\-\s]?\d{3}[.\-\s]?\d{4}$").unwrap();
let string = "+1(425)-888-8080";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}