const regex = /<\/?a\b[^>]*?\/?>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<\\\/?a\\b[^>]*?\\\/?>', 'gm')
const str = `Leave <anyother> in. This is a string that contains <a id=something>multiple</a> instan<a href=one thing/>ces of the <a href=another thing>codes</a> that I want to strip out.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}