$re = '/<\/?a\b[^>]*?\/?>/m';
$str = 'Leave <anyother> in. This is a string that contains <a id=something>multiple</a> instan<a href=one thing/>ces of the <a href=another thing>codes</a> that I want to strip out.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);