re = /<\/?a\b[^>]*?\/?>/m
str = 'Leave <anyother> in. This is a string that contains <a id=something>multiple</a> instan<a href=one thing/>ces of the <a href=another thing>codes</a> that I want to strip out.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end