#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)1[1-9]|20|6[5-9]|[7-9][0-9]|10[01]"
Local $sString = "10" & @CRLF & _
"11" & @CRLF & _
"12" & @CRLF & _
"14" & @CRLF & _
"20" & @CRLF & _
"21" & @CRLF & _
"64" & @CRLF & _
"65" & @CRLF & _
"101" & @CRLF & _
"102" & @CRLF & _
"100" & @CRLF & _
"70" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")