// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)1[1-9]|20|6[5-9]|[7-9][0-9]|10[01]").unwrap();
let string = "10
11
12
14
20
21
64
65
101
102
100
70
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}