re = /1[1-9]|20|6[5-9]|[7-9][0-9]|10[01]/m
str = '10
11
12
14
20
21
64
65
101
102
100
70
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end