using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"1[1-9]|20|6[5-9]|[7-9][0-9]|10[01]";
string input = @"10
11
12
14
20
21
64
65
101
102
100
70
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}