#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "@import \b.*[\"']([^)]*)[\"']"
Local $sString = "@import url("fineprint.css") print;" & @CRLF & _
"@import url("bluish.css") projection, tv;" & @CRLF & _
"@import 'custom.css';" & @CRLF & _
"@import url("chrome://communicator/skin/");" & @CRLF & _
"@import "common.css" screen, projection;" & @CRLF & _
"@import url('landscape.css') screen and (orientation:landscape);"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")