using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@import \b.*[\""']([^)]*)[\""']";
string input = @"@import url(""fineprint.css"") print;
@import url(""bluish.css"") projection, tv;
@import 'custom.css';
@import url(""chrome://communicator/skin/"");
@import ""common.css"" screen, projection;
@import url('landscape.css') screen and (orientation:landscape);";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}