package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`@import \b.*[\"']([^)]*)[\"']`)
var str = `@import url("fineprint.css") print;
@import url("bluish.css") projection, tv;
@import 'custom.css';
@import url("chrome://communicator/skin/");
@import "common.css" screen, projection;
@import url('landscape.css') screen and (orientation:landscape);`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}