// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"@import \b.*[\"']([^)]*)[\"']"#).unwrap();
let string = "@import url(\"fineprint.css\") print;
@import url(\"bluish.css\") projection, tv;
@import 'custom.css';
@import url(\"chrome://communicator/skin/\");
@import \"common.css\" screen, projection;
@import url('landscape.css') screen and (orientation:landscape);";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}