# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<([^>]+?)([^>]*?)>(.*?)<\\/\1>/\1 /gs;t' <<< "^(?=.*?\bdog\b)((?!cat).)*$
<([^>]+?)([^>]*?)>(.*?)<\/\1>
This is the second paragraph. It contains an ordered list:
<ol>
<li>Item 1</li>
<li>Item 2</li>
<li>Item 3</li>
</ol>
This is a text after the list in the second paragraph.
This is another part of a paragraph
<ol>
<li>Item 1</li>
<li>Item 2</li>
<li>Item 3</li>
</ol>
This is a text after the another list in the second paragraph.
This is a text after the list in the second paragraph.
This is another part of a paragraph
<ol>
<li>Item 1</li>
<li>Item 2</li>
<li>Item 3</li>
</ol>
test to odfjdf iofsdfsoh
"