#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)<([^>]+?)([^>]*?)>(.*?)<\/\1>"
Local $sString = "^(?=.*?\bdog\b)((?!cat).)*$" & @CRLF & _
"<([^>]+?)([^>]*?)>(.*?)<\/\1>" & @CRLF & _
"This is the second paragraph. It contains an ordered list: " & @CRLF & _
"<ol>" & @CRLF & _
" <li>Item 1</li>" & @CRLF & _
" <li>Item 2</li>" & @CRLF & _
" <li>Item 3</li>" & @CRLF & _
" </ol>" & @CRLF & _
" This is a text after the list in the second paragraph." & @CRLF & _
" This is another part of a paragraph" & @CRLF & _
" <ol>" & @CRLF & _
" <li>Item 1</li>" & @CRLF & _
" <li>Item 2</li>" & @CRLF & _
" <li>Item 3</li>" & @CRLF & _
" </ol>" & @CRLF & _
" This is a text after the another list in the second paragraph." & @CRLF & _
"This is a text after the list in the second paragraph." & @CRLF & _
" This is another part of a paragraph" & @CRLF & _
" <ol>" & @CRLF & _
" <li>Item 1</li>" & @CRLF & _
" <li>Item 2</li>" & @CRLF & _
" <li>Item 3</li>" & @CRLF & _
" </ol>" & @CRLF & _
"test to odfjdf iofsdfsoh" & @CRLF & _
""
Local $sSubst = "\1 "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)