$re = '/<([^>]+?)([^>]*?)>(.*?)<\/\1>/s';
$str = '^(?=.*?\\bdog\\b)((?!cat).)*$
<([^>]+?)([^>]*?)>(.*?)<\\/\\1>
This is the second paragraph. It contains an ordered list:
<ol>
<li>Item 1</li>
<li>Item 2</li>
<li>Item 3</li>
</ol>
This is a text after the list in the second paragraph.
This is another part of a paragraph
<ol>
<li>Item 1</li>
<li>Item 2</li>
<li>Item 3</li>
</ol>
This is a text after the another list in the second paragraph.
This is a text after the list in the second paragraph.
This is another part of a paragraph
<ol>
<li>Item 1</li>
<li>Item 2</li>
<li>Item 3</li>
</ol>
test to odfjdf iofsdfsoh
';
$subst = "\1 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;